HDU 2955 Robberies (01背包)

Robberies

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5181    Accepted Submission(s): 1958


Problem Description
The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.


For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.


His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.
 

 

Input
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
 

 

Output
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.
 

 

Sample Input
3 0.04 3 1 0.02 2 0.03 3 0.05 0.06 3 2 0.03 2 0.03 3 0.05 0.10 3 1 0.03 2 0.02 3 0.05
 

 

Sample Output
2 4 6
 

 

Source
 

 

Recommend
gaojie
 
 
挺有意思的题目,需要点转化。01背包:每个物品代价是每个银行钱的数目,物品的价值是在该银行不被抓的概率 (1-被抓概率),背包容量是所有银行钱的总和。01背包求dp[i]表示获得i的钱不被抓的最大概率。最后从大到小枚举出 dp[i]>=(1-P)这个i就是答案了。
#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>
using namespace std;
const int MAXN=110;
double dp[10010];
int value[MAXN];
double weight[MAXN];

int nValue,nKind;

void ZeroOnePack(int cost,double weight)
{
    for(int i=nValue;i>=cost;i--)
       dp[i]=max(dp[i],dp[i-cost]*weight);
}
int main()
{
    int T;
    double P;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%lf%d",&P,&nKind);
        nValue=0;
        for(int i=0;i<nKind;i++)
        {
            scanf("%d%lf",&value[i],&weight[i]);
            weight[i]=1-weight[i];
            nValue+=value[i];
        }
        memset(dp,0,sizeof(dp));
        dp[0]=1;
        for(int i=0;i<nKind;i++)
          ZeroOnePack(value[i],weight[i]);
        for(int i=nValue;i>=0;i--)
          if(dp[i]>=1-P)
          {
              printf("%d\n",i);
              break;
          }
    }
    return 0;
}

 

posted on 2012-09-14 10:20  kuangbin  阅读(458)  评论(0编辑  收藏  举报

导航

JAVASCRIPT: